Duisburger Zoo

Der Editor wird geladen. Bitte warten. …

Duisburger ZooSchon seit einer Weile nervt mich im Firefox mein Typo3-Backend mit dieser Meldung (siehe oben) Immer wenn ich einen Text editieren will, passiert – NICHTS. Der „htmlArea RTE“ wurde einfach nicht geladen. Bisher hatte ich mich immer damit beholfen, den „Rich Text Editor“ abzuschalten. Das musste ich aber immer wieder auf jeder Seite machen und dann noch jeweils zwei Meldungen wegklicken. Die erste war klar:

Diese Änderung beeinflusst die zur Verfügung 
stehenden Eingabefelder. Wollen Sie 
gemachten Änderungen sichern und die 
Anzeige aktualisieren?

– Wollen wir! Aber außerdem meinte das zweite Fenster, ich sei ausgeloggt!? (Ihr Login ist abgelaufen…) – Dort musste ich dann auf „Abbrechen“ klicken und weiter ging es.
Heute wollte ich seit langem mal wieder ein paar Texte editieren. Die zweite Meldung war ja noch leicht abzuschalten. Ich hatte vergessen im „htmlArea RTE“ die Configurations-Optionen für den Firefox an zuschalten. Im Bereich „Installation status“ blieb aber weiterhin die Meldung:

Double installs? A "System" extension with this key is 
also available on the server, but cannot be loaded 
because the "Local" version takes precedence.

Duisburger ZooErst bei Jan Loderhose: „TYPO3-Update – Stolperfallen vermeiden“ fand ich dann den entscheidenden Hinweis. Tatsächlich war der „htmlArea RTE“ sowohl lokal als auch im System vorhanden. Scheinbar erkennt man das im „Extension Manager“ in der Spalte „Type:“ am Eintrag „Local SL„. Also hielt ich mich an Jan und löschte erst mal den lokalen „htmlArea RTE“ :

  • Im „Extension Manager“ unter „Install Extensions“ auf „htmlArea RTE“ klicken.
  • Mit dem Klick kommt man in die „Information“-Seite zur entsprechenden Erweiterung. Dort dann auf die Zeile „Click here to remove the extension: Remove Extension“ klicken.
  • Nun ist die Extension aber erst deaktiviert, jetzt muss man die Extension noch löschen: Dazu wählt man oben im Dropdown-Menü „Backup/Delete“ aus. Jetzt noch auf „DELETE EXTENSION FROM SERVER (in the „Local“ location …“ klicken
  • – „Are you sure..„?
  • – „OK„! und weg ist sie. ;-)
  • Jetzt noch zurück in den „Extension Manager“ und dort den Installed extension... „htmlArea RTE“ wieder aktivieren,
  • Datenbank aktualisieren,
  • alle Caches löschen –
  • und, zumindest bei mir, war alles wieder gut. :-o

Duisburger ZooDie Erweiterung „htmlArea RTE“ gibt es jetzt nur noch im „System“.

Beim Durchsehen des „Extension Manager“ fand ich dann auch noch zwei andere Kandidaten für eine analoge Behandlung. Die Extensions „Web>View (viewpage)“ und „Indexed Search Engine (indexed_search)“ sahen genauso aus.
Für letztere war noch die Extension „doc_indexed_search“ nötig.
Außerdem musste ich mein System noch aktualisieren:

# apt-get install xpdf-utils unzip catdoc xlhtml ppthtml unrtf
....
# for pp in pdftotext unzip catdoc xlhtml ppthtml unrtf ; do echo -n "$pp " ;which $pp ||echo "FEHLER" ;done
pdftotext /usr/bin/pdftotext
unzip /usr/bin/unzip
catdoc /usr/bin/catdoc
xlhtml /usr/bin/xlhtml
ppthtml /usr/bin/ppthtml
unrtf /usr/bin/unrtf
# 

Die Pfade konnte ich dann noch in die Konfiguration der Erweiterung „Indexed Search Engine (indexed_search)“ einwerfen und speichern.
Nun klappt wieder alles und ich bin zufrieden.
Danke noch mal an Jan.

About the Author

Uwe

Uwe beschäftigt sich seit vielen Jahren mit Linux und Webdesign, seit 2006 benutzt er WordPress zum schreiben eines "Tagebuchs". Tätig ist Uwe als Webmaster und Netzwerkadministrator, er arbeitet und lebt seit 2001 in Oberhausen. In seiner Freizeit ist er viel mit dem Mountainbike und dem Fotoapparat unterwegs.

2 thoughts on “Der Editor wird geladen. Bitte warten. …

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.