debian auf den HP ProLiant G7 MicroServer N54L

HP ProLiantHeute Früh weckte mich der Postbote und er brachte den lang ersehnten neuen Server. Mein bisheriger HomeServer war derart in die Jahre gekommen, dass ich langsam Angst bekam. Meine letzten Versuche den Server abzulösen, liegen inzwischen auch schon wieder ein paar Jahre zurück und nun wollte/musste ich mir langsam mal eine Alternative zum anstehenden Daten-Totalverlust überlegen. Von Kollegen hatte ich schon einige Schwärmerei über den HP ProLiant MicroServer abbekommen und so bestellte ich ihn mir nun auch. Heute Früh war er nun wirklich da. :)
Als Betriebssystem kommt selbstverständlich auch hier nur Debian 7.1 (Wheezy) in Frage. ;) Mangels optischer Laufwerke, bereitete ich mir also wieder einen USB-Stick für die Installation vor und fing an, die nötigen Komponenten zusammen zu tragen.
neue FestplatteDas erste Problem ergab sich schon vor dem Hochfahren. Der Stick war fertig und ich wollte die Installations-Umgebung aufbauen, da stellte ich fest, dass ich ja gar keine USB-Tastatur im Haus habe. Für die vorhandene Tastatur hatte bestimmt mal einen Adapter von PS2 auf USB gehabt, aber wo ist der hin? :( Dann fiel mir ein, dass auf dem Osterfelder Stadtfest ja auch ein Flohmarkt ist und so rief ich Tandeyqjadeyqdeyq an, ob sie dort mal schaut. Tatsächlich fand sie eine neue Tastatur, aber weil sie nun doch noch dort helfen wollte, musste ich mir die Tastatur selber abholen. Der ProLiant erkannte die Tastatur auch ganz gut, aber wirklich nutzbar war sie dennoch nicht. Weil mein 12″ Monitor nur den Text-Modus bei der Installation verträgt und auch nur den ohne FrameBuffers, wollte ich den Installer entsprechend ‚instruieren‘:

[ESC-Taste]
install vga=normal fb=false

Main-BoardAber die Taste ‚a‘ funktionierte nicht – und auch nicht die ‚q‘- und die ‚y‘-Taste. :evil: Das wäre auch wirklich das erstemal, dass ich auf einem Flohmarkt etwas ‚technisches‘ kaufe, dass dann zu Hause auch wirklich funktioniert. Also bin ich nochmal zum Stadtfest und habe mir meine 10 Euro wiedergeben lassen. Er versuchte mir zwar erst noch eine ‚komplett schwarze‘ Tastatur aufzuschwatzen – aber wer einmal lügt… – Ich hatte jedenfalls keinen Bock noch eine Tastatur von dem Typen auszuprobieren und sauer genug war ich ja wohl auch…

Erst mit Marvins Tastatur konnte ich dann loslegen und den Boot-Parameter vollständig eingeben.
Als ich dann das meiste installiert hatte, kopierte ich den bisherigen Übergangsserver und tauschte die beiden aus. ( smith:~# rsync -prau –one-file-system / usmith:/home/smith_all\$/ )

MainBoardAls nächstes bin ich dann am Grub noch fast verzweifelt. Irgendwann nach dem x-ten Reboot waren nämlich plötzlich die ‚FrameBuffers‘ wieder da und ich bekam es nicht mehr hin, die FrameBuffers auszuschalten… Sämtlich Einstellungen in der ‚/etc/default/grub‘ brachten immer das selbe Ergebnis – nämlich einen für mich unbenutzbaren Screen an der Console. Erst deutlich später, stellte ich fest, dass Grub schon tut was man ihm sagt. Erst kurz danach, irgendwo in dem Bereich wenn der ‚kbd oder ‚console-setup‘ startet, wird die Auflösung so eigenartig umgeschalten. Noch später stellte ich dann fest, dass es am Parameter des Radeon-Moduls lag. Erst als ich für dieses Modul in der Datei ‚/etc/modprobe.d/radeon-kms.conf‘ den Parameter für das radeon-KMS power-management aus-geschalten hatte (‚options radeon modeset=0‘) konnte ich die Text-Console durchgängig benutzen.

Gelesen: 3191 · heute: 2 · zuletzt: Fri 23.August 2019

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.