OwnCloud v.7.0.1 Kalender-Problem - Action-Icon fehlen

Unfreiwilliges Update auf OwnCloud 7.0.1

2014OwnCloud v7.0.1 Durcheinander-LayoutDen ganzen restlichen Tag musste ich mich um meine OwnCloud-Installation kümmern. Ich hatte nämlich leichtsinnigerweise über den internen Update-Center ein Backup machen lassen wollen. Das Plugin war dann so frei auch gleich ein Update von meiner bisherigen Version 6.0.4 auf die aktuelle 7.0.1 zu machen. :evil:
OwnCloud v.7.0.1 Kalender-Problem - Action-Icon fehlenDer Updater zeigte einige success-Meldungen und als letztes ein einfaches Error ohne sonstige sachdienliche Hinweise, außer der Aussage, dass ich das fixen soll. Na schönen Dank auch! Tatsächlich lief zuerst gar nichts. Es gab eine weiße Seite und auch in den Fehlerlogs tauchte nur selten etwas brauchbares auf. Ich hatte die externen Plugins vorher ja nicht deaktiviert / deaktivieren können – und nun waren sie nicht mehr vorhanden – womöglich war das ein Problem?! Nach einer Weile wildem Basteln konnte man sich dann aber doch wieder anmelden. Das Webinterface sah nun tatsächlich etwas anders/neuer aus. Die bisher linke Leiste mit den Anwendungen war nach oben in ein Pulldown-Menü gewechselt und damit auf kleineren Displays übersichtlicher geworden. Dann hörten die Verbesserungen aber auch schon auf. Das restliche Layout war ziemlich durcheinander und sieht entsprechend blöd aus. Die Suche (rechts oben) funktioniert scheinbar gar nicht mehr und der Kalender ist gleich ziemlicher Schrott. Die Freigabe-Links der Kalender sind und bleiben auch nach Trickserei mit Firebug unsichtbar. Dabei müsste ich unbedingt eine Freigabe ändern. Der Kalender-Dialog für die Auswahl des Tages scheint gleich mehrere Macken zu haben. Auch bei der Galerie-App scheint noch viel Arbeit liegen geblieben zu sein.
Im ApacheLog sah ich massenhaft 404er-Meldungen. Ein Aufruf der Lesezeichen-App erzeugt gleich mal etliche Zeilen – und entsprechend sieht dass was da im Browser ankommt auch aus.
Noch ‚fataler‘ war es im ErrorLog von OwnCloud. Dort liefen die ‚fatal‘-Zeilen durch wie bei einem Wasserfall, innerhalb weniger Minuten kamen hunderte Zeilen zusammen.

Die Probleme und Log-Auszüge der endlosen Pleite-Installation habe ich mal auf die zweite Seite verbannt. Denn …

OwnCloud v7.0.1 Layout OK… am Sonntag gab es doch tatsächlich ein kurzes Happyend. Es stellte sich heraus, dass die Anzeige-Probleme tatsächlich an fehlenden css-Definitionen lagen.
Das Problem war bei mir, dass ich es per Apache-Definition verbiete die .htaccess-Dateien im Verzeichnisbaum einzulesen. Ich übernehme statt dessen deren Inhalt in eine Datei im /etc/apache2/-Pfad und binde sie von dort in die VituallHost-Definition ein. Ich habe den Unterschied zwischen den Versionen für 5.x/6.x und 7.x zwar jetzt nicht untersucht, aber nachdem ich die 7er-Einträge übernommen hatte, sahen die (meisten) Apps oberflächlich wieder gut aus.
Bleiben also ’nur‘ noch die Probleme mit der Suche, bei der Kalender-App, der gar nicht funktionierenden Aufgaben-App, und was sonst noch so in den Fehler-logs auftauchte.

Dazu werde ich aber in den nächsten Tagen noch ein wenig schreiben, denn in meinen Augen ist OwnCloud spätestens mit der Version 7 tot. – Hier geht es nicht mehr um die tatsächliche Benutzbarkeit im täglichen Leben, sondern nur noch darum, in Präsentationen gut auszusehen. – Schämt Euch!

Tags :

About the Author

Uwe

Uwe beschäftigt sich seit vielen Jahren mit Linux und Webdesign, seit 2006 benutzt er WordPress zum schreiben eines 'Tagebuchs'. Tätig ist Uwe als Webmaster und Netzwerkadministrator, er arbeitet und lebt seit 2001 in Oberhausen. In seiner Freizeit ist er viel mit dem Mountainbike und dem Fotoapparat unterwegs.

1 thought on “Unfreiwilliges Update auf OwnCloud 7.0.1

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.