Schon wieder – diesmal aber 2.9.1

nun aber schnellGerade lese ich so ganz nebenbei etwas von ‚WordPress 2.9.1 veröffentlicht‚ – WordPress, WordPress, wer war das gleich nochmal? – Aber solche Wortfindungsstörungen sind bei WordPress ja eher auszuschließen! ;-) Hier gibt es genügend Updates, um immer wieder rechtzeitig erinnert zu werden.
Aber Spaß beiseite, heute Früh war es wiedermal so weit. –
Allerdings hätte ich schon gedacht, dass das 2.9er Pingback-Problem jetzt auch wieder gefixt ist. – Diesen Fix musste zumindest ich wieder selber machen.. :-(
Ich hatte doch aber schon die aktuellste Version ??! in der aber dennoch eine alte cron.php war:

# wget -N „http://counter.wordpress-deutschland.org/dlcount.php?id=static&url=/de-edition/latest.zip“
# ls -l latest.zip
-rw-r–r– 1 uwe uwe 2757975 5. Jan 00:00 latest.zip
# unzip …

# ls -l ./blog/wp-includes/cron.php
-rw-r–r– 1 root root 11634 8. Dez 19:59 ./blog/wp-includes/cron.php
# cat ./blog/wp-includes/version.php | grep wp_version
….
$wp_version = ‚2.9.1‘;
#

Meine Pingbacks kamen auch tatsächlich nicht an, obwohl gerade dieser Bug auf der Ankündigungsseite explizit als gelöst erwähnt ist…
Schlimmer noch, ich hatte plötzlich übelste Probleme mit der Load. Ob es nun wirklich an dem geringen TimeOut-Parameter lag oder an anderen zufälligen Dingen weiß ich nicht. Jedenfalls musste ich zwischendurch meinen Webserver zweimal neu starten. Und erst als ich dann den alten TimeOut-Wert (1.00) in die cron.php eingetragen hatte, lief der Server wieder normal. – Mysteriös –

Ach ja, an der Datenbank hatte sich aber offensichtlich nicht geändert:

….
Ein Upgrade ist nicht erforderlich

Deine WordPress-Datenbank ist aktuell!

Nachtrag:
Eines meiner Probleme lag offensichtlich an einer fehlerhaften Zeitzonen-Verarbeitung. Ich hatte nämlich beim Veröffentlichen von Artikel eine falsche Uhrzeit (UTC) drinstehen. Das Problem lag am Timezone-Plugin. Allerdings vermute ich mal, dass das Plugin auch schon unter WP 2.9 (bei mir) fehlerhaft lief. Nach dem ich es deaktiviert habe, passen die Zeiten jedenfalls wieder.

Gelesen: 2500 · heute: 2 · zuletzt: Thu 15.August 2019

2 Responses to “Schon wieder – diesmal aber 2.9.1

  • Es gab kein Bug in der cron.php. Der Fehler lag in der http.php. Die cron.php wurde gar nicht angerührt, deshalb auch noch die ‚Alte‘.

  • Habe ich schon gerade bei Matthias geschrieben:

    Ich vermute auch, dass das Pingback-Problem 
    nicht primär am TimeOut-Parameter liegt. Deshalb hatte 
    ich heute Früh beim Senden des Artikels auch (mit 
    dem Wert 0.01) diese extrem hohe Last.
    Ich denke mal, dass dann bei Pingpacks eine Schleife 
    entsteht, weil nach 0.01 sec. noch nichts passiert ist, 
    versucht er (wer auch immer) es nochmal und nochmal 
    usw. bis der Apache steht..

    Mit einem hoch gesetzten TimeOut waren die Last-Probleme dann weg.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.